Tuesday, August 30, 2022

Upgrading To 9.0 From 8.x

Impact: High

PHP 8.0.2 Required

Laravel now requires PHP 8.0.2 or greater.

Composer Dependencies

You should update the following dependencies in your application's composer.json file:

  • laravel/framework to ^9.0
  • nunomaduro/collision to ^6.1

In addition, please replace facade/ignition with "spatie/laravel-ignition": "^1.0" and pusher/pusher-php-server (if applicable) with "pusher/pusher-php-server": "^5.0" in your application's composer.json file.

Furthermore, the following first-party packages have received new major releases to support Laravel 9.x. If applicable, you should read their individual upgrade guides before upgrading:

Finally, examine any other third-party packages consumed by your application and verify you are using the proper version for Laravel 9 support.

No comments:

Post a Comment